
Upgrading and Installing Fiery JDF or Fiery API
Fiery Integration Manager

Overview

This document describes how to upgrade the Fiery JDF or Fiery API to the latest version using the Fiery Integration
Manager. This document is intended for the system administrator or service representative responsible for installing
or upgrading the Fiery JDF or Fiery API.

Note: This document refers to the Fiery server running on the Windows operating system or the Fiery Central
server.
Before you start, obtain the following information from the site administrator:

• IP address or DNS name of the Fiery server you want to upgrade

• The password for the Administrator of the Fiery server

About the Fiery Integration Manager

The Fiery Integration Manager is a software utility that allows you to install or upgrade the Fiery JDF or Fiery API
component of the Fiery server, and configure the Fiery JDF settings and options from a remote computer.
You must install the Fiery Integration Manager from the Fiery Software Manager. You can perform the following
tasks using the Fiery Integration Manager:

• Install the latest Fiery JDF on the Fiery server or upgrade the Fiery JDF to the latest version.

• View or modify the current Fiery JDF Setup settings.

• View or modify the Fiery JDF configuration options.

• Install the latest Fiery API on the Fiery server or upgrade the Fiery API to the latest version.

Note: The Fiery Integration Manager is available only on Windows client computers.
You use the Fiery Integration Manager to connect to the target Fiery server when installing or upgrading the Fiery
JDF.

Start the Fiery Integration Manager and connect to a Fiery server

1 From the Windows Start menu, select All Programs > Fiery > Fiery Integration Manger.

2 Click Connect.

3 In the Connect to Server window, type the IP address or DNS name of the Fiery server in the Connect to a server
field and click Connect.
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You can add the Fiery server to the Favorite list by clicking . To delete a Fiery server from the Favorite list,
select the Fiery server and click .

You can search for the Fiery server by clicking . Select the following search criteria from the Search menu and
click Go:

• Select Auto Search to search for the Fiery server in the same subnet as your client computer running the
Fiery Integration Manager.

• Select Subnet to search for the Fiery server in a specific subnet. For example, if you want to search for the
Fiery server in subnet 10.100.234.xxx, type 10.100.234.0 in the From field and 255.255.255.0 in the To field.

• Select IP Range to search for the Fiery server in a particular IP range. For example, if you search for the Fiery
server with the IP address 10.100.234.xxx, type 10.100.234.0 in the From field and 10.100.234.255 in the To
field.

4 In the Login window, enter the password for Administrator, and click Login.

Supported Fiery system software

To determine your Fiery server software version, print the Fiery server configuration page, and locate the Fiery
server section and then the Software section on the page. You can also log on to the Fiery server using Fiery
Command WorkStation with Device Center. In Device Center, select the General tab, then click General Info, and
check the Fiery System field.
The Fiery Integration Manager supports Fiery servers with Fiery system software FS200/200 Pro and later.

Enabling the Fiery Productivity Package or Fiery Automation Package on the Linux-
based Fiery server

If you want to install the Fiery JDF on a Linux-based Fiery server running Fiery system software FS200, FS300, or
FS350, you need to enable Fiery Productivity Package on the Fiery server. For information about the Fiery
Productivity Package Option Kit, contact your authorized service or support center.
For Fiery servers running Fiery system software FS400 and later, Fiery servers, the Fiery Automation Package
replaced the Fiery Productivity Package. For a list of supported Fiery servers, see https://www.fiery.com/en-gb/
products/cutsheet/fiery-jdf/#supported-printers.

Enable the Fiery Productivity Package or Fiery Automation Package

1 Log on to the Fiery server using either Fiery Command WorkStation or WebTools.
For more information, see the Configuration and Setup Guide that is part of the user documentation set.

2 Do one of the following:

• In Fiery Command WorkStation, open Device Center, select the General tab, click General Info, and click
Manage.

• In WebTools, click the Home tab and click Manage.
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3 Use the controls in the activation window to activate the license.
You need the License Activation Code (LAC) that is included in Productivity Package or Automation package
Option Kit to activate the Fiery Productivity Package or Fiery Automation Package. For more information, click
the  link in the activation window.

Note: Keep the License Activation Code in the Fiery Productivity Package or Fiery Automation Package.

4 Restart the Fiery server when you finish the license activation.

Fiery JDF and Fiery API procedures

You need to follow one of the procedures to upgrade the Fiery JDF version, and view or modify the Fiery JDF settings
and options.
See the table to determine which procedure you need to perform.

For procedure:

Upgrade the Fiery JDF on the Windows-based Fiery server on page 3

Upgrade or install the Fiery JDF on the Linux-based Fiery server on page 4

View or modify the JDF Setup on page 4

Specify the Fiery JDF configuration options on page 5

Upgrade the Fiery JDF on the Fiery Central server on page 5

Install or upgrade the Fiery API on the Fiery server on page 6

Install or upgrade the Fiery API on the Fiery Central server on page 6

Upgrade the Fiery JDF on the Windows-based Fiery server

1 Make sure the Fiery server is not receiving, processing, or printing jobs.
Notify the site administrator that the Fiery server will be unavailable during the upgrade.

2 Start the Fiery Integration Manager and connect to the Fiery server to upgrade.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.
If the "Server has the latest version FJDF" message is shown, you do not have to proceed. Click Disconnect and
exit the Fiery Software Manager.
If the Upgrade button is shown in the Fiery Software Manager window, the latest Fiery JDF version is available.
Proceed with step 3 on page 3.

Note: The latest Fiery JDF version will be displayed to the left side of the Upgrade button.

3 Click Upgrade.

4 When the message states the changes were made, click OK.
The Fiery Server reboots automatically with the latest Fiery JDF version installed.

Upgrading and Installing Fiery JDF or Fiery API

Fiery Integration Manager

3



5 Select File > Exit to exit the Fiery Integration Manager.

6 Print the Fiery server configuration page and verify the Fiery JDF version.
Locate the JDF Setup section and check if the Fiery JDF version is the latest.

Upgrade or install the Fiery JDF on the Linux-based Fiery server

1 Make sure the Fiery server is not receiving, processing, or printing jobs.
Notify the site administrator that the Fiery server will be unavailable during the upgrade or installation.

2 Start the Fiery Integration Manager and connect to the target Fiery server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.
If the "Server has the latest version FJDF" message is shown, you do not have to proceed. Click Disconnect and
exit the Fiery Software Manager.
If the Upgrade button is shown in the Fiery Software Manager window, the latest Fiery JDF version is available.
Proceed with step 3 on page 4.

Note: The latest Fiery JDF version is displayed to the left of the Upgrade button.
If the Install button is shown in the Fiery Software Manager window, the latest Fiery JDF version is available for
the new installation. Proceed with step 3 on page 4.

3 Click Upgrade or Install.

4 In the Login window, enter the password for Administrator, and click Login.

View or modify the JDF Setup

1 Start the Fiery Integration Manager and connect to the Fiery server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.

2 Click JDF Setup.

3 View or modify the following options as necessary:

• Enable JDF

• Default JDF Setting And Action

• Close Job

• Common Global Path

Note: The JDF Setup options are available only when Enable JDF is selected. The available options may vary
depending on the version of the connected Fiery server.

4 If you changed any options, click Apply, or click Cancel to clear the changes.

5 When the message states the changes were made, click OK.
The Fiery server reboots automatically with the new JDF Settings, causing the connection to the Fiery server to
be lost.
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6 Select File > Exit to exit the Fiery Integration Manager.

Upgrade the Fiery JDF on the Fiery Central server

1 Start the Fiery Integration Manager and connect to the Fiery Central server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.
If the "Server has the latest version FJDF" message appears, you do not have to proceed. Click Disconnect and
exit the Fiery Integration Manager.
If the Upgrade button is shown in the Fiery Software Manager window, the latest Fiery JDF version is available.
Proceed with step 2 on page 5.

Note: The latest Fiery JDF version is displayed to the left of the Upgrade button.

2 Click Upgrade.
The Fiery Integration Manager downloads the installer for Fiery JDF and saves the installer file in C:\EFI\Server
\system of the Fiery Central server.

Note: The drive name (C:) may differ depending on the system configuration.

3 Log on to the Fiery Central server as an Administrator.

4 Open C:\EFI\Server\system folder and double-click the FJDF Installer.exe file.

5 Follow the on-screen instructions to complete the upgrade.

6 To check the Fiery JDF version, connect to the Fiery Central server with the Fiery Command WorkStation. Open
Device Center, select the General tab, then click Server, click Configuration, and click JDF Setup to check the
Fiery JDF version.

Specify the Fiery JDF configuration options

1 Start the Fiery Integration Manager and connect to the Fiery server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.

2 Click Configure Options.
The tab shows all the configurable options supported by the Fiery server.

3 Specify the configuration options as necessary.
For more information, see Fiery JDF Configuration Options on page 7.

4 If you have changed any options, click Apply, or click Cancel to clear the changes.

5 When the message states the changes were made, click OK.
The Fiery server reboots automatically with the new configuration options, causing the connection to the Fiery
server to be lost.

6 Select File  > Exit to exit the Fiery Integration Manager.
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Install or upgrade the Fiery API on the Fiery server

1 Make sure the Fiery server is not receiving, processing, or printing jobs.
Notify the site administrator that the Fiery server will be unavailable during the upgrade or installation.

2 Start the Fiery Integration Manager and connect to the target Fiery server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.
If the "Server has the latest Fiery API version" message is shown, you do not have to proceed. Click Disconnect
and exit the Fiery Software Manager.
If the Upgrade button is shown in the Fiery Software Manager window, the latest Fiery API version is available.
Proceed with the step 3 on page 6.

Note: The latest Fiery API version is displayed the to left of the Upgrade button.
If the Install button is shown in the Fiery Software Manager window, the latest Fiery API version is available for
the new installation. Proceed with step 3 on page 6.

3 Click Upgrade or Install.

4 A message is displayed to notify you that the changes will be in effect after the Fiery server is rebooted. Click OK
to continue.

5 Select File > Exit to exit the Fiery Integration Manager.

Install or upgrade the Fiery API on the Fiery Central server

1 Start the Fiery Integration Manager and connect to the Fiery Central server.
For more information, see Start the Fiery Integration Manager and connect to a Fiery server on page 1.
If the "Server has the latest Fiery API version" message is shown, you do not have to proceed. Click Disconnect
and exit the Fiery Integration Manager.
If the Upgrade button is shown in the Fiery Software Manager window, the latest Fiery API version is available.
Proceed with step 2 on page 6.

Note: The latest Fiery API version is displayed to the left of the Upgrade button.
If the Install button is shown in the Fiery Software Manager window, the latest Fiery API version is available for
the new installation. Proceed with step 2 on page 6.

2 Click Upgrade or Install.
The Fiery Integration Manager downloads the installer for Fiery API and saves the installer file in C:\EFI\Server
\system of the Fiery Central server.
The drive name (C:) may differ depending on the system configuration.

3 Log on to the Fiery Central server as an Administrator.

4 Open C:\EFI\Server\system folder and double-click the Agali Installer.exe file.

5 Follow the on-screen instructions to complete the upgrade or installation.
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Fiery JDF Configuration Options

You can set the configuration options on the Configure Options tab in the Fiery Software Manager window.

Note: A Fiery server may not support all the available options.

Configuration options

Delete Job Record - If selected, the job is not tracked by the Fiery JDF after the job is printed, closed, or deleted.
AutoCreate DevCap - If selected, the Fiery JDF automatically creates a Device Capabilities (DevCap) file at the
startup based on the information from the JDF-compatible device.
AutoCreate RuleFile - When the Fiery JDF service restarts, a mapping file between JDF and the Fiery job options is
created dynamically to allow new JDF features to be added without a product-specific patch.
PDF Box - You can specify if the Fiery JDF allows you to change the following page boxes in the PDF file to a specific
box. If the page box specified is not in the PDF file, the Fiery JDF will not modify the PDF file.

• TrimBox

• CropBox

• BleedBox

• MediaBox

• ArtBox

Logging options

File Logging - The Fiery JDF logs are stored in E:\EFI\server\spool\csiatom\logs.
JDF Logging - The JDF files are captured in E:\EFI\server\spool\csiatom\cache\JDF.
Signal Logging - Outgoing signal JMF messages are stored in E:\EFI\server\spool\csiatom\cache\JDF.
JMF Logging - Incoming JMF messages are stored in E:\EFI\server\spool\csiatom\cache\JDF.

Note: The log files stored in these folders are only for debugging purposes.
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